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1. INTRODUCTION

In the modern professional landscape, proficiency in computing software is no longer
optional — it is a fundamental competency expected of every business graduate. PRC
110: Software Skills Practicum is a one-credit practical course offered in Year 1, Semester
I of the Bachelor of Business Administration (BBA) programme at Pokhara University.
The course is designed to equip students with hands-on skills in using the computer as a
productivity tool, covering four essential software environments: MS Windows (for
software installation and network configuration), MS Word (for document creation and
formatting), MS Excel (for data analysis and computation), and MS PowerPoint (for
professional presentation design).

Unlike conventional theory-based subjects, PRC 110 is evaluated entirely through
continuous assessment — including attendance, class participation, assignments, and this
lab report — rather than a semester-end examination. This structure reflects the course's
emphasis on demonstrable, practical ability over rote memorisation.

This lab report documents all the practical tasks completed across the four course units
during the semester. Each unit section presents the tasks undertaken, the skills applied,
and screenshots as evidence of the work performed. The document itself has been
prepared in Microsoft Word, intentionally applying the formatting techniques covered in
Unit II: font styling through Word Styles, automated Table of Contents, headers and
footers, figure captions, and page layout settings.

The goal of this report is to consolidate learning from the practicum, demonstrate
competence in each software tool, and serve as a reference document reflecting the
practical skills acquired throughout the semester.

Note to students: In your own report, replace the placeholder screenshot boxes below with
actual screenshots taken during your practical sessions. Ensure every screenshot is cropped
to show only the relevant portion, resized to fit within the page margins, and captioned
using Insert > Caption in Word.
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2. UNIT I: INSTALLING SOFTWARE IN A COMPUTER

Unit I provided an introduction to the categories of software and the practical process of
installing applications on a Windows computer, including configuring basic network
settings. These skills form the foundation for working efficiently in any computing
environment.

2.1 Types of Software

Software is broadly classified into system software and application software. System
software manages hardware resources and provides the platform on which applications
run. Application software performs specific user-oriented tasks.

Category Description Examples

Operating System Manages hardware and provides core
services for all programs

Windows 11, macOS
Ventura, Ubuntu 24.04

Utility Software Performs maintenance tasks to keep the
system running smoothly

Windows Defender,
CCleaner, 7-Zip

Programming
Software

Tools for writing and debugging code Visual Studio Code, Python
IDLE

Productivity
Software

Applications for creating documents,
spreadsheets, and presentations

MS Word, MS Excel, MS
PowerPoint

Statistical
Software

Performs data analysis and statistical
computation

SPSS, R, Stata

[Screenshot: Windows 11 desktop with the Start menu open showing pinned and recommended apps]

Figure: Windows 11 Start Menu showing categorised applications
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2.2 Installing MS Office

During the practical session, Microsoft Office was installed on the lab computer
following the steps below:

1. Downloaded the Office setup file from the Microsoft 365 portal using the institution's
licensed account.

2. Double-clicked the installer (OfficeSetup.exe) to launch the setup wizard.

3. Accepted the End User License Agreement (EULA).

4. Chose the default installation directory (C:\Program Files\Microsoft
Office).

5. Waited for the installation to complete (approximately 8 minutes on the lab network).

6. Activated the product by signing in with the institutional Microsoft account.

[Screenshot: Microsoft Office installation progress bar at approximately 70%, showing Word, Excel,
PowerPoint icons]

Figure: Microsoft Office installation in progress

[Screenshot: Office activation screen showing "Product Activated" confirmation for Microsoft 365]

Figure: Microsoft Office successfully activated

A similar process was followed to install SPSS Statistics. The key difference was that
SPSS required a separate licence key to be entered during installation, which was
provided by the faculty.
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2.3 Network Setup

Network configuration was performed to connect the lab computer to the institution's
local area network and gain internet access. The following settings were configured:

IP Address Configuration

The IP address was set using the Network and Sharing Centre. The adapter was
configured with a static IP address assigned by the network administrator:

IP Address: 192.168.1.45

Subnet Mask: 255.255.255.0

Default Gateway: 192.168.1.1

DNS Servers: 8.8.8.8 (Primary), 8.8.4.4 (Secondary)

[Screenshot: Windows Network Adapter Properties dialog showing IPv4 settings with static IP, subnet mask,
gateway, and DNS filled in]

Figure: Static IP address configuration in Windows Network Settings

Firewall and Antivirus Check

Windows Defender Firewall was verified to be active through Control Panel > System
and Security > Windows Defender Firewall. The firewall status showed the domain,
private, and public network profiles all enabled. Windows Security (Antivirus) was also
confirmed to be up to date with the latest virus definitions.

[Screenshot: Windows Defender Firewall status page showing all three network profiles (Domain, Private,
Public) as "on"]

Figure: Windows Defender Firewall confirmed active for all network profiles
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3. UNIT II: MS WORD

Unit II covered the core document creation and formatting capabilities of Microsoft Word
2021. The skills practised range from basic font styling to advanced automation features
such as mail merge, automated Table of Contents, and tracked revisions.

3.1 Font and Paragraph Formatting

The Font group on the Home tab provides controls for typeface, size, colour, bold, italic,
underline, strikethrough, superscript, subscript, and text highlight. The Paragraph group
provides alignment, indentation, line spacing, and list formatting options.

In practice, a passage of unformatted text was reformatted to demonstrate the difference.
The heading was styled as Times New Roman, 14 pt, Bold; body text as Times New
Roman, 12 pt, Justified; and a pull-quote was formatted as Times New Roman, 11 pt,
Italic, centred.

Best practice: Always apply formatting through Word Styles (Home > Styles) rather than
manually changing font size and weight. This ensures the Table of Contents and navigation
pane remain functional.

[Screenshot: Word document with the Styles gallery open on the Home ribbon, showing Heading 1 applied to
a section title and Normal style applied to body text]

Figure: Applying Word Styles — Heading 1 for section titles and Normal for body text
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3.2 Page Layout

Page layout settings were configured through the Layout tab. The following settings were
applied for this report, matching the lab report formatting guidelines:

Paper size: A4 (210 mm × 297 mm)

Top and Bottom margins: 1.0 inch (2.54 cm)

Left margin: 1.25 inches (3.18 cm)

Right margin: 1.0 inch (2.54 cm)

Line spacing: 1.5 lines

Paragraph spacing after: 6 pt

[Screenshot: Word Page Setup dialog (Layout tab > Margins dialog box) showing margin values of 1 inch
top/bottom, 1.25 inch left, 1 inch right, and A4 paper size selected]

Figure: Page setup — A4 paper with 1.25 inch left margin and 1 inch other margins

3.3 Headers, Footers, and Page Numbering

Headers and footers were inserted using Insert > Header / Footer. The Different First
Page option was enabled so that the cover page has no header or footer.

Header (left): PRC 110: Software Skills Practicum

Header (right): Rajan Sharma

Footer (centre): Page X of Y (inserted via Insert > Quick Parts > Field > Page and
NumPages)

[Screenshot: Word document in header editing mode showing "PRC 110: Software Skills Practicum" on the
left and the student name on the right, with the Header & Footer Tools ribbon visible]

Figure: Header editing view — course name left-aligned, student name right-aligned
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3.4 Tables

A table was created using Insert > Table to organise sample data. Table styles were
applied through the Table Design tab. Borders were set to 0.5 pt solid black, and the
header row was shaded with a dark background and white text.

[Screenshot: Word table with a shaded header row (dark blue background, white bold text) and alternating
row shading, Table Design ribbon visible at top]

Figure: Sample formatted table — header row shading with alternating row colours applied

3.5 Automated Table of Contents and References

An automated Table of Contents was generated by navigating to References > Table of
Contents and selecting the Automatic Table 2 style. This populated the TOC based on the
Heading 1, Heading 2, and Heading 3 styles already applied throughout the document.

Footnotes were inserted at the bottom of the relevant page using References > Insert
Footnote. Citations were managed through References > Manage Sources, and the
bibliography was auto-generated using References > Bibliography > Insert Bibliography
in APA style.

[Screenshot: Word References ribbon with "Table of Contents" dropdown open, showing Automatic Table
options; the document shows an already-generated TOC below]

Figure: Generating an automatic Table of Contents from applied Heading styles
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3.6 Mail Merge

The Mail Merge feature was demonstrated by creating a personalised letter for a set of
five recipients. The process used the Mailings tab Step-by-Step Mail Merge Wizard:

1. Selected document type: Letters.

2. Used the current document as the starting document.

3. Created a new recipient list with fields: First Name, Last Name, Address, City.

4. Inserted merge fields (<<First_Name>>, <<Address>>) into the letter body.

5. Previewed the merged letters and verified each recipient's data was populated
correctly.

6. Completed the merge to a new document containing all five personalised letters.

[Screenshot: Word Mailings tab showing the Step-by-Step Mail Merge Wizard pane on the right with step 4 of
6 active, and merge field placeholders visible in the document body]

Figure: Mail Merge Wizard — inserting merge fields into a letter template

3.7 Proofing, Track Changes, and Comments

Spelling and grammar checking was performed using Review > Spelling & Grammar
(keyboard shortcut F7). Errors highlighted in red were corrected, and grammatical
suggestions shown in blue were reviewed.

Track Changes was enabled using Review > Track Changes. Edits made while tracking
was on appeared in red with underline for insertions and strikethrough for deletions. A
comment was inserted using Review > New Comment to annotate a section for the
reviewer's attention.

[Screenshot: Word document with Track Changes and Comments visible — red underlined insertion,
strikethrough deletion, and a comment bubble on the right margin with reviewer text]
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Figure: Track Changes enabled — showing an insertion (underlined), deletion (strikethrough), and a
comment
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4. UNIT III: MS EXCEL

Unit III was the most extensive unit, covering data management, analysis, and
computational skills using Microsoft Excel 2021. A sample dataset of student marks
across five subjects was used as the primary data source for most exercises in this unit.

4.1 Data Entry and Formatting

A worksheet named Student Marks was created with the following structure: Student
Name, Roll No, English, Mathematics, Science, Computer, Nepali, Total, and Percentage.
Data for 10 students was entered manually.

Cell formatting was applied as follows:

Header row: Bold, white text, dark blue fill, centred alignment, borders on all sides.

Numeric columns: Number format with 2 decimal places.

Percentage column: Percentage format (e.g., 78.40%).

Column widths: Adjusted using Format > AutoFit Column Width.

[Screenshot: Excel spreadsheet with 10 rows of student data, formatted header row in dark blue, alternating
row shading, and number-formatted mark columns]

Figure: Student Marks spreadsheet — data entry with applied cell formatting
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4.2 Sort, Filter, and Conditional Formatting

The dataset was sorted in descending order of Percentage using Data > Sort. A filter was
then applied using Data > Filter to display only students who scored above 75% — the
filter dropdown showed a custom number filter: "Greater Than 75".

Conditional formatting was applied to the Percentage column using Home > Conditional
Formatting > Colour Scales (Green–Yellow–Red) to visually indicate performance levels
at a glance.

[Screenshot: Excel spreadsheet with filter dropdowns visible on the header row, only rows with Percentage >
75 showing, and the Percentage column shaded with a green-to-red colour scale]

Figure: Filter applied for Percentage > 75 with conditional formatting colour scale

4.3 Cell Referencing

Three types of cell references were demonstrated in practice:

Relative reference (=B2+C2): Adjusts automatically when copied to other rows.

Absolute reference (=$H$2): Locks the reference; used for a fixed bonus value
applied to all rows.

Mixed reference (=B$1*C2): Locks either the row or column; useful in
multiplication tables.

[Screenshot: Excel sheet with the formula bar showing =SUM(C2:G2) for the Total column, and a separate
section demonstrating $H$2 absolute reference in a bonus calculation column]

Figure: Cell referencing — relative reference for Total column, absolute reference for fixed bonus value
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4.4 Functions

The following Excel functions were practised using the Student Marks dataset:

Function Category Formula Used Result

SUM Math =SUM(C2:G2) Total marks for each
student

AVERAGE Statistical =AVERAGE(C2:C11) Class average for
English

MAX / MIN Statistical =MAX(H2:H11) Highest and lowest
total marks

COUNT /
COUNTA

Statistical =COUNTA(A2:A11) Number of students
in the list

IF Logical =IF(I2>=45,"Pass","Fail") Pass/Fail based on
percentage

COUNTIF Statistical =COUNTIF(J2:J11,"Pass") Count of students
who passed

VLOOKUP Lookup &
Reference

=VLOOKUP(A14,A2:J11,10,0) Look up a student's
grade by name

TODAY /
DATE

Date & Time =TODAY() Current date, auto-
updated

[Screenshot: Excel sheet showing column J labeled "Result" with IF formula in the formula bar returning Pass
or Fail, and column K showing VLOOKUP formula looking up a student name from a search cell]

Figure: IF and VLOOKUP functions applied to the student marks dataset
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4.5 Pivot Table and Chart

A Pivot Table was created from the Student Marks dataset to summarise the average
marks per subject. The process:

1. Selected the data range A1:J11.

2. Navigated to Insert > PivotTable and placed it on a new sheet named Summary.

3. Dragged Subject fields (English, Mathematics, Science, Computer, Nepali) to the
Values area, summarised as Average.

A clustered bar chart was then inserted from the Pivot Table to visually compare subject
averages.

[Screenshot: Excel Pivot Table on the Summary sheet showing average marks per subject, with the PivotTable
Fields panel on the right. A clustered bar chart is visible showing the subject averages.]

Figure: Pivot Table summarising average marks per subject, with accompanying bar chart

4.6 Linking Workbooks and Worksheets

A second worksheet named Grade Sheet was created within the same workbook. A cross-
sheet reference was used to pull the student's Percentage from the Student Marks sheet:
='Student Marks'!I2. This demonstrated that changes to the source sheet
automatically update the Grade Sheet, maintaining data consistency across worksheets.

[Screenshot: Excel workbook with two sheet tabs (Student Marks and Grade Sheet) visible at the bottom. The
Grade Sheet is active, showing a formula in the formula bar referencing the other sheet: ='Student Marks'!I2]

Figure: Cross-sheet reference — Grade Sheet pulling percentage data from Student Marks sheet
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5. UNIT IV: MS POWERPOINT

Unit IV focused on creating professional presentation slides using Microsoft PowerPoint
2021. A five-slide presentation on "The Importance of Digital Literacy in Business" was
created to practise all required features.

5.1 Slide Layout and Design

The presentation used the Title Slide layout for the opening slide and the Title and
Content layout for body slides. The built-in Office Theme — Slate design was applied
from the Design tab, providing a consistent dark-header, light-body colour scheme.

Typography hierarchy was maintained:

Slide title: Calibri 36 pt, Bold

Body text level 1: Calibri 24 pt

Body text level 2: Calibri 20 pt, Italic

[Screenshot: PowerPoint Design tab with the Slate theme selected and highlighted, showing the presentation
with consistent dark-navy headers and light body areas across three visible slides in the thumbnail panel]

Figure: Design tab — Slate theme applied consistently across all slides
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5.2 Inserting Elements

The following elements were inserted into the presentation:

Image: A royalty-free image of a business meeting was inserted via Insert > Pictures
> Stock Images, resized, and positioned.

Shape: A rounded rectangle callout was added using Insert > Shapes with a custom
fill colour to highlight a key statistic.

SmartArt: A Cycle SmartArt graphic was inserted to illustrate the digital literacy skill
cycle.

Chart: A pie chart was inserted showing the proportion of time spent on different MS
Office tools by business professionals.

Hyperlink: A text box with a URL was converted to a hyperlink using Insert > Link.

[Screenshot: PowerPoint slide showing a SmartArt Cycle diagram with five nodes (Read, Write, Calculate,
Present, Communicate) in the Slate theme colours, with the SmartArt Design ribbon active]

Figure: SmartArt Cycle diagram illustrating the digital literacy skill cycle

5.3 Transitions and Animations

A Fade transition (duration 0.70 seconds) was applied to all slides using Transitions >
Apply to All. Object-level animations were added on slide 3:

The title entered with an Appear animation (On Click).

Each bullet point appeared with a Wipe from Left animation, triggered automatically
after the previous item with a 0.5-second delay.

[Screenshot: PowerPoint Animation pane open on the right, showing numbered animation entries (1. Title box
– Appear, 2-5. Body text bullets – Wipe) with the Transitions pane showing Fade transition selected at the top

of the ribbon]
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Figure: Animation pane showing entry animations for slide elements; Fade transition applied to all slides
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5.4 Slide Master and Slide Show Settings

The Slide Master was accessed through View > Slide Master. The following
customisations were made to ensure brand consistency across all slides without
modifying each slide individually:

Added the college logo placeholder to the top-right corner of the Master slide.

Set a consistent footer with the course name and slide number on all layouts.

Modified the body text font to Calibri throughout all layouts from the Master.

[Screenshot: PowerPoint in Slide Master view (View > Slide Master ribbon visible), showing the master slide
with a logo placeholder in the upper right and the footer text on the bottom of the master]

Figure: Slide Master view — logo placeholder and footer customised for all slides

The Slide Show was configured using Slide Show > Set Up Slide Show. The show type
was set to Presented by a speaker (full screen), the advance slides option was set to
Manually, and Use Presenter View was enabled to display speaker notes on the presenter's
screen while showing the presentation full-screen to the audience.

[Screenshot: Set Up Show dialog box in PowerPoint with "Presented by a speaker" radio button selected,
"Manually" selected under Advance slides, and the "Use Presenter View" checkbox ticked]

Figure: Set Up Show dialog — presenter mode configured with manual slide advance
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6. CONCLUSION AND REFLECTION

Completing PRC 110: Software Skills Practicum has been a genuinely transformative
experience. Before this course, my interaction with computers was largely passive —
browsing, watching videos, and typing basic documents. After working through the four
units systematically, I now approach the computer as a productivity instrument with a
measurable set of skills that I can deploy purposefully.

Of the four units, I found MS Excel most challenging and, ultimately, most rewarding.
The concept of cell referencing — particularly the distinction between relative, absolute,
and mixed references — initially seemed confusing, but once I understood why the dollar
sign locks a row or column, a wide range of formulas became intuitive. Functions such as
VLOOKUP and IF opened my eyes to how spreadsheets can act as simple decision-
support systems. I can already imagine using these tools to manage budgets, track
inventory, or analyse survey data in a business context.

MS Word surprised me the most. I had always typed documents manually and formatted
them visually. Learning to use Styles, automated Tables of Contents, and Mail Merge
showed me how much time is wasted by students and professionals who do not know
these features. The lab report itself was prepared entirely using these techniques, which
gave me practical confidence that I could not have gained from reading alone.

The unit on installing software and network configuration (Unit I) gave me a vocabulary
and framework for understanding the computing environment — something I had taken
for granted before. And MS PowerPoint (Unit IV) reinforced that good presentation
design is about restraint and hierarchy, not decoration.

The primary challenge I faced was managing my time during the Excel practical sessions,
as the volume of functions to cover in six hours was significant. I addressed this by
practising exercises at home using the sample datasets provided and referring to the
course notes.

Looking ahead, I am confident that these skills will serve me throughout my BBA
programme — in preparing project reports, analysing data for research papers, and
presenting findings professionally. More fundamentally, this practicum has shifted my
attitude: I now see software tools not as obstacles to navigate but as skills to master.
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